MH-ET LIVE Tiny88(16.0Mhz)

  • @tedbecker87
    It is confirmed at the moment they are unusable, it would be enough to compile new drivers. But I think the support is dead

  • I've been having issues too

  • @Ghibli_69 Same problem for this driver installation that failed. But down the list, I noticed, a more recent version of the digistump driver was successfully installed.
    I was able to upload a code on my board just by following instructions above, and even with this driver error.
    However, I spent many hours searching if there was a way to use a virtual com port to communicate with the computer, but I didn't find anything working.
    This board works great but it's difficult to debug without sending messages with a serial interface.

  • @Gatis @Ghibli_69 Yes I also had the exact same problem. But that doesn't prevent programming the board, I made a video for that:

  • If it helps, I made a video for it. I manage to program the attiny88 under Windows 10 well even with the error message (USB not recognized etc).
    Tell me if it works for you.

  • I posted another video, please watch this one first:
    normally it should work like this (tested successfully on 3 pc)

  • ola pessoal estava com todos estes ploblemas citados acima, o codigo nao estava copilando pra placa de forma nenhuma, mais quando apertei o reset da placa no momento de passar o codigo copilou normalmente

  • I still have win7 now in 2022. And I encounter a slight bug when I installed the 2.0a4 driver in the beginning. The driver installation freezed. After shutting down the entire installation (from my Process Explorer) and re-instal the 2.0a4 driver again, it managed to finalize the installation. I did everything on this page that is recommended to boot up and run the first program and it worked for me. It sucks I must unplug and re-plug the usb cord while programming it. In a word, it works for me.

  • I am trying to write to SCL and SDA pins of the board.
    I am using a couple of MCP23017 linked to these 2 pins (also with common ground). This program I am using is working fine with Arduino UNO. But here with Tiny I get these 2 big errors:
    email me at if you know how to resolve this problem. Thank you.
    Here is the entire code I used:

  • Hi everyone, I got this MH-Tiny up and running with nRF24l01. It works well and the price to performance is amazing. I got it working with Arduino IDE. Tips: Just treat it as a regular Arduino board and you don't have to unplug the device, just press the reset button, and the board will disconnect and reconnect back.IMG_4542.jpg

  • @q12 Keep the device plugin and press the reset button to disconnect and reconnect it back when asked to plug the device.

  • @MH-ET-LIVE said in MH-ET LIVE Tiny88(16.0Mhz):

    • Built-in USB
    • 26 I/O Pins (2 are used for USB only if your pogram actively comunicates over USB, otherwise you can use al 6 evn if you are progaming via USB)

    OK, but which pins are used by USB?

  • @bato3 said in MH-ET LIVE Tiny88(16.0Mhz):

    OK, but which pins are used by USB?

    I'm found:

    D+, D-, LED, Jumper, D+ on INT0?

    PD2, PD1, PD0, PC7, Yes

  • Some attiny88 sometimes have a bootloader problem, that's why these modules can't be programmed by USB. This problem is present if when you plug in your card or you press reset and the red led does not flash.

    This problem is quite easy to solve, just install a special library and re-burn the bootloader.
    I made a video to help people who have this problem:

    I hope it can help too.

  • If you preffer reading, is possible upload micronucleus bootloader (V-USB) over ISP (avrdude)..

  • @bato3 i already read all that, but is to much hard for me, if you can help me out, i really appreciate :D

  • Hi guys I have this Attiny88 board but can not get it to work with the PlatformIO interface.
    The Red LED is flashing when powered on via usb cable.

    I get this Error :
    C:\Users\johna.platformio\packages\framework-arduino-avr-attiny\cores\tiny\wiring.c: In function 'init':
    C:\Users\johna.platformio\packages\framework-arduino-avr-attiny\cores\tiny\wiring.c:1095:8: error: #error "Frequency requested from internal oscillator that cannot be generated by prescaling"
    #error "Frequency requested from internal oscillator that cannot be generated by prescaling"
    Compiling .pio\build\attiny88\FrameworkArduino\wiring_pulse.c.o
    C:\Users\johna.platformio\packages\framework-arduino-avr-attiny\cores\tiny\wiring.c:1096:8: error: #error "Custom tuning is not supported in the current version of ATTinyCore"
    #error "Custom tuning is not supported in the current version of ATTinyCore"

    Kindest any suggestions ??


  • I have solved it , this is my settings in platformIO.ini file:
    platform = atmelavr
    board = attiny88
    framework = arduino
    board_build.f_cpu = 16000000L

    ; change clock source if needed
    build_flags = -DCLOCK_SOURCE=18
    ; new clock source
    ;build_flags = -DCLOCK_SOURCE=17

    upload_protocol = micronucleus

    also I needed to download
    used this driver :
    Ibusb-win32 (v1.2.6.0)

    check this tutorial :

    end of message

  • Guys, I have problem with the serial monitor I cant get it to work


    I have this ini file


    any suggestions ??

  • I have now used the #include <SoftwareSerial.h> with this ini file on platformIO

    To make it work I load code over usb interface then switch to USB to ttl dongle and read rx tx over serial monitor.

    I would like to use //#include <DigiCDC.h> //serial monitor
    But this one i cant get to work. Does not detect com port

    platform = atmelavr
    board = attiny88
    framework = arduino
    board_build.f_cpu = 16000000L
    build_flags = -DCLOCK_SOURCE=18 -Wno-narrowing
    upload_protocol = micronucleus
    lib_deps =


    // this works, must use USB to ttl adapter and tx is Rx on the out and inpins
    const byte rxPin = 3 ; // RX is D3 - on TTL it is TX
    const byte txPin = 4 ; // TX is D4 - on TTL it is RX

    SoftwareSerial mySerial(rxPin, txPin);

    void setup() {
    pinMode(rxPin, INPUT);
    pinMode(txPin, OUTPUT);


    void loop (){

Log in to reply